Please help me with my planted tank

Discuss anything related to aquatic plants and aquascaping
Forum rules
Before you start posting in this forum, will suggest you to go through the forum rules
HERE

Re: Please help me with my planted tank

Postby Dipankar » Sat Jul 15, 2017 10:34 am

Source of this shit is from drift and exploded due to heavy light
User avatar
Dipankar
Die Hard KAC Fan
Die Hard KAC Fan
 
Posts: 1515
Images: 11
Joined: Wed Aug 28, 2013 5:17 pm
Location: Nawa City Rajasthan
Has thanked: 35 times
Been thanked: 38 times

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Orkut Orkut

Re: Please help me with my planted tank

Postby MotshoBotsho » Mon Jul 17, 2017 11:17 am

Its probably a bacterial bloom from the driftwood by the looks of it (as some others have also remarked). There may have been a nutrient spike resulting from the plants getting uprooted.

My suggestions won't be very different from what the rest have suggested.
Remove what you can manually and take out the driftwood and wash it or boil it if you can, periodic water changes will help, shorten the photo period.

If you still have issues with these blooms or other types of Algae investing in a UV sterilizer might help.
User avatar
MotshoBotsho
New KAC Member
New KAC Member
 
Posts: 44
Joined: Mon Feb 15, 2016 7:43 am
Has thanked: 9 times
Been thanked: 1 time

Previous

Return to Planted Tank Discussion

Who is online

Users browsing this forum: No registered users and 1 guest