I hate algae !!!

Discuss anything related to aquatic plants and aquascaping
Forum rules
Before you start posting in this forum, will suggest you to go through the forum rules
HERE

I hate algae !!!

Postby jack » Thu Apr 27, 2017 11:08 am

Hello everyone

I have BGA in my tank ... rather it looks like BGA to me and when i say i hate algae means i literally hate algae

Attached are the pics of algae in the tank

Basic info of the tank

Tank is been running more than a year with no mortality in discus.
6X2X2 main display with wood and some ferns and anubias
5X2x2 sump with 12 nos of marine pure blocks
1 fluval fx5
2 filter socks on overflow
I always like over filteration and less stocking so fishes health is not compromised
Have 16 discus, 6 whiptails, 3 bristlenose

Tank is situated outside in compound where it gets ambient light
No direct sunlight
Light in the tank is for 2 hours 6:30 to 8:30 pm just simple led 4 foot tube and plants have decent growth
No fert dosing since 6 months
Only ro water change
Once a week around 20%
Tds is 82
Nitrate, nitrite, amonia all 0 not trackable

Every week i syphon this algae and still within 2-3 days it bounces back. This problem i am facing since 2 months now.

Thank you

Image
Image
Image
Image


Sent from my iPhone using Tapatalk
jack
Regular in KAC
Regular in KAC
 
Posts: 279
Joined: Sat Mar 16, 2013 1:40 pm
Has thanked: 0 time
Been thanked: 0 time

Share On:

Share on Facebook Facebook Share on Twitter Twitter Share on Orkut Orkut

Re: I hate algae !!!

Postby mithun » Sun May 14, 2017 3:31 pm

i am suspicious about your test kit.. with all zero its not possible to get that quick algae Come-back.. what is your wc schedule?

Sent from my MI 4W using Tapatalk
Mithun
M:8583865385
Napoleon Bonaparte wrote:If you want something done in a better way, do it yourself.

My 220Gal reef journal | My 150Gal reef journal
User avatar
mithun
Super Moderator
Super Moderator
 
Posts: 2664
Images: 0
Joined: Tue Mar 20, 2012 11:03 pm
Location: Bangalore.. :(
Has thanked: 4 times
Been thanked: 35 times

Re: I hate algae !!!

Postby jack » Sun May 14, 2017 6:07 pm

mithun wrote:i am suspicious about your test kit.. with all zero its not possible to get that quick algae Come-back.. what is your wc schedule?

Sent from my MI 4W using Tapatalk


WC lately every alternate day around 30%


Sent from my iPhone using Tapatalk
jack
Regular in KAC
Regular in KAC
 
Posts: 279
Joined: Sat Mar 16, 2013 1:40 pm
Has thanked: 0 time
Been thanked: 0 time

Re: I hate algae !!!

Postby mithun » Sun May 14, 2017 7:02 pm

alternate day WC shouldnt be building up so much nutrient... you are doing everything OK,, even plecos are in to eat the algae up.. check your nutrient level with a new test kit.. phosphate n nitrates would do. live stock is low so i think your source water has a problem!
Mithun
M:8583865385
Napoleon Bonaparte wrote:If you want something done in a better way, do it yourself.

My 220Gal reef journal | My 150Gal reef journal
User avatar
mithun
Super Moderator
Super Moderator
 
Posts: 2664
Images: 0
Joined: Tue Mar 20, 2012 11:03 pm
Location: Bangalore.. :(
Has thanked: 4 times
Been thanked: 35 times

Re: I hate algae !!!

Postby jack » Mon May 15, 2017 4:09 am

Water source is RO with 08 TDS and 55 TDS of tank
Nitrate and nitrite both are 0




Sent from my iPhone using Tapatalk
jack
Regular in KAC
Regular in KAC
 
Posts: 279
Joined: Sat Mar 16, 2013 1:40 pm
Has thanked: 0 time
Been thanked: 0 time

Re: I hate algae !!!

Postby SanamMarik » Mon May 15, 2017 4:27 am

bro, is the algae slimy typ?
Sanam Marik
Knowledge has no end and so is my love for it. :)
User avatar
SanamMarik
KAC Fanatic
KAC Fanatic
 
Posts: 2445
Images: 0
Joined: Wed Nov 27, 2013 10:03 pm
Has thanked: 0 time
Been thanked: 92 times

Re: I hate algae !!!

Postby jack » Mon May 15, 2017 5:03 am

Nope its not ...
jack
Regular in KAC
Regular in KAC
 
Posts: 279
Joined: Sat Mar 16, 2013 1:40 pm
Has thanked: 0 time
Been thanked: 0 time

Re: I hate algae !!!

Postby SanamMarik » Mon May 15, 2017 5:23 am

i think its cyanobacteria only as you have zero nitrates...you need to keep some nitrates in the tank if u want your plants to do well and this algae to vanish... you can aim for 5ppm no3 to begin with
Sanam Marik
Knowledge has no end and so is my love for it. :)
User avatar
SanamMarik
KAC Fanatic
KAC Fanatic
 
Posts: 2445
Images: 0
Joined: Wed Nov 27, 2013 10:03 pm
Has thanked: 0 time
Been thanked: 92 times

Re: I hate algae !!!

Postby jack » Mon May 15, 2017 6:14 am

Ohkiee


Sent from my iPhone using Tapatalk
jack
Regular in KAC
Regular in KAC
 
Posts: 279
Joined: Sat Mar 16, 2013 1:40 pm
Has thanked: 0 time
Been thanked: 0 time

Re: I hate algae !!!

Postby mithun » Mon May 15, 2017 7:12 am

thats cyano only.. That's a green slime algae that grows like sheet on the substrate. Thought it has definite period after which it will disappear, but a leeching substrate can cause that to last longer.. if you dont see it go away after a month consider changing the substrate to an inert one!
Mithun
M:8583865385
Napoleon Bonaparte wrote:If you want something done in a better way, do it yourself.

My 220Gal reef journal | My 150Gal reef journal
User avatar
mithun
Super Moderator
Super Moderator
 
Posts: 2664
Images: 0
Joined: Tue Mar 20, 2012 11:03 pm
Location: Bangalore.. :(
Has thanked: 4 times
Been thanked: 35 times

Next

Return to Planted Tank Discussion

Who is online

Users browsing this forum: No registered users and 1 guest